ProductsSystem requirements

Last Updated 2016-12-06

System requirements

JMAG 32-bit (Note 4)
Operating System
(Note 1)  (Note 3)(Note 5)
Windows 8.1 Pro
Windows 7 Ultimate, Professional
Windows Server 2008
CPU Intel 32-bit (recommended):
- Intel Core i Series
- Intel Xeon Series
RAM 4GB (recommended)
* The amount of memory required depends on the number of necessary elements and conditions used for an analysis.
Hard disk Min. 40GB free space (recommended)
Other OpenGL compatible graphics board
Ethernet board (network card)
JMAG 64-bit
Operating System
(Note 1)(Note 5)
Windows 10 Pro
Windows 8.1 Pro
Windows 7 Ultimate, Professional
Windows Server 2012R2
Windows Server 2012
Windows Server 2008 R2
Windows Server 2008
Red Hat Enterprise Linux 5, 6 (Note 2)
SUSE Linux Enterprise 11 (64-bit) SP2 or later (Note 2)
CPU Intel 64-bit (recommended):
- Intel Core i Series
- Intel Xeon Series
AMD 64-bit (recommended):
- AMD 64 Series
RAM Min. 4 GB (approx. 2.5 million elements when running an analysis)
* The amount of memory required depends on the number of necessary elements and conditions used for an analysis
Hard disk Min: 40GB free space (recommended)
Other OpenGL compatible graphics board
Ethernet board (network card)

[Note 1]
- We ceased providing technical support for Microsoft Windows XP as of April 9, 2014.
   Notice Regarding Cessation of Technical Support for Microsoft Windows XP
- We ceased providing technical support for Windows Server 2003 as of July 15, 2015.
- We ceased providing technical support for Windows 8 as of January 12, 2016.

[Note 2]
Linux Full Edition is supported by Red Hat Enterprise Linux 6 (64-bit) and SUSE Linux Enterprise 11 (64-bit) SP2 or later.

[Note 3]
The 32-bit version of JMAG Linux module Solver Edition is no longer supported by JMAG-Designer 14.1 or later.

[Note 4]
We will cease providing technical support for Microsoft Windows 32-bit versions of JMAG-Designer following 15.1.
  Notice Regarding Cessation of Technical Support for Windows 32-bit JMAG-Designer

[Note 5]
Windows Vista is no longer supported in JMAG-Designer version 15.1 or later.
  Notice of JMAG Technical Support Discontinuation for Windows Vista

Versions for Linking JMAG to Third-party Software

Importing CAD Models (InterOp)
JMAG-Designer Ver.16.0 CATIA v5 R8 - R25 (V5 - 6R2016)
CATIA v4 CATIA 4.1.9 - CATIA 4.2.4
IGES - 5.3
PTC Creo Parametric*
(*Formerly Pro/ENGINEER)
16 - Creo 3.0
NX Direct NX1 - NX10
Solid Edge Direct V18 - ST8
SOLIDWORKS Direct 2003 - 2016
Parasolid Direct 9.0.* - 28.0.*
STEP 203, 214
JMAG-Designer Ver.15.1 CATIA v5 R8 - R25 (V5 - 6R2015)
CATIA v4 CATIA 4.1.9 - CATIA 4.2.4
IGES - 5.3
PTC Creo Parametric*
(*Formerly Pro/ENGINEER)
16 - Creo 3.0
NX Direct NX1 - NX10.0.0
Solid Edge Direct V18 - ST7
SOLIDWORKS Direct 2003 - 2015
Parasolid Direct 9.0.* - 27.0.*
STEP 203, 214
Linking to CAD Systems (Linking to SOLIDWORKS)
JMAG-Designer Ver.16.0
JMAG-Designer Ver.15.1
SOLIDWORKS 2014 - 2016
Linking to CAD Systems (CAPRI)
JMAG-Designer Ver.16.0
JMAG-Designer Ver.15.1
CAPRI V3.21.3 CATIA v5 R21, R22, R23, R24, R25 (Note 1)
PTC Creo Parametric
Creo 1.0, Creo 2.0 (Note 2), Creo3.0
NX NX7.5, NX8.0, NX8.5, NX9, NX10 (Note 1)
Importing SAT Files
JMAG-Designer Ver.16.0 - Ver.R26
JMAG-Designer Ver.15.1 - Ver.R25
SPEED
JMAG-Designer Ver.16.0
JMAG-Designer Ver.15.1
SPEED - 2008
Script languages (Python)
JMAG-Designer Ver.16.0 Python 2.7.10 (Windows), 2.7(Linux Full Edition) (Note 4)
Microsoft Script Debugger
(VB Script, JScript)
Microsoft Visual Studio 2013 or later
JMAG-Designer Ver.15.1 Python 2.7.10 (Windows), 2.7(Linux Full Edition)
Python for Windows Extensions Build 213, Build 214
Optimization
JMAG-Designer Ver.16.0 MATLAB Global Optimization Toolbox R2013a, R2013b, R2014a, R2014b, R2015a, R2015b, R2016a, R2016b
JMAG-Designer Ver.15.1 MATLAB Global Optimization Toolbox R2013a, R2013b, R2014a, R2014b, R2015a, R2015b, R2016a (Note 3)
Coupled analysis
JMAG-Designer Ver.16.0
JMAG-Designer Ver.15.1
SIMULIA Abaqus One-way coupled 6.10-2, 6.13, 6.14, 2016
Two-way coupled (CSE) 6.14, 2016
The modules necessary to link to a control simulator
Please see JMAG-RT Solutions for the system requirements.

[Note 1] Only the 64-bit versions of CATIA V5 R24, R25, NX9.0, and NX10 are supported.
[Note 2] The manufacture code M40 or later for Creo2.0 is required in order to link with Creo2.0.
[Note 3] Only the 64-bit versions of R2016a is supported.
[Note 4] Installed by default in JMAG Installer.

SMP Solver

System Requirements for Parallel Accelerator 2

The number of solver licenses and parallel accelerator 2 (hereinafter called PA2) licenses required for 8 parallel calculation are as follows:

Standard calculation:1 solver license
2 parallel tasks:1 solver license + 1 PA2 license
4 parallel tasks:1 solver license + 2 PA2 licenses
8 parallel tasks:1 solver license + 4 PA2 licenses

* The SMP parallel solver is available for ST, TR, DP (excluding FEM+BEM), and FQ in JMAG version 9.1 and later.

Recommended CPUs:

  • Intel® Xeon® 5500 series, 5600 series (Up to 4 parallel tasks with 1 CPU or 8 parallel tasks with 2 CPUs)
  • Intel® Xeon® E5 series or higher, or a CPU with a high performing memory bus

Please contact us if you intend to use any CPU that is not listed above.

MPP Solver

The number of solver licenses (hereafter called MPS) required for up to 64 parallel calculations are as follows:

Less than 16 parallel tasks:2 MPS licenses
17-32 parallel tasks:3 MPS licenses
33-64 parallel tasks:4 MPS licenses

* Please contact us if you wish to perform more than 64 parallel processes.
* The MPP solver is available for ST, TR, DP (excluding FEM+BEM), and FQ in JMAG-Designer Ver.13.0 and later.

Recommended system requirements:

  • CPU: Intel® Xeon® E5 series or higher, or a CPU with a high performing memory bus
  • Network between the nodes: Infiniband

Please contact us if you intend to use any CPU that is not listed above.

Supported systems:

Operating Systems:

  • Only 64-bit is supported.
    Confirm the OS version that supports the MPI library from among the versions described in the JMAG operating environment.
    Refer to information from the original provider regarding OS versions that support the MPI library.

MPI library:

  • JMAG-Designer Ver.16.0, JMAG-Designer Ver.15.1
    Intel MPI Library 5.0 (runtime package support)

Please contact us regarding other operating environments.

GPU Support

JMAG-Designer officially supports GPUs from Ver.12.0.
Those who would like to use it, please contact our sales department for more information.

JMAG GPU solver supports only GPU for math calculation made by NVIDIA. The following GPUs are currently supported:

  1. Tesla K40
  2. Quadro K6000
  3. Tesla K20
  4. Quadro 6000
  5. Tesla C2075
  6. Tesla C2070
  7. Tesla C2050

It is recommended to use the most recent GPU available to take full advantage of the GPU solver.
Windows 64-bit is the only platform supported by JMAG GPU solver.
Static, transient response, and frequency response magnetic field analyses are also supported.

Supported Job schedulers

  • LSF
  • PBS
  • Torque
  • Slurm
  • Condor

Supported Cloud Systems

  • FOCUS
  • IBM Softlayer
  • AWS
  • FUJITSU Cloud
  • Rescale Platform

Using JMAG on Virtual Machines

The JMAG license system does not currently support license management for virtual machines.
Please follow the instructions below to use JMAG on a virtual machine.

  1. Obtain licenses issued for the physical address of a computer that is not a virtual machine to use as the license server.
  2. Run JMAG on the virtual machine as a client.

The following restrictions for managing licenses will be removed as soon as the JMAG license system supports virtual machines.

*The system requirements change as needed. Please contact us for more information.

Top of Page

Contact US

Free Trial